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Introduction

Presentation

Curvus Pro has been developed in order to provide a quick user-friendly and
powerful tool for graphing any kind of two- and three-dimensional algebraic
relation such as:

* Any explicit, implicit or parametric curve and graph

» 2D and 3D vector fields

» 2D and 3D scalar (density) fields

» Solutions of differential equations up to the third order
» 2D logical relations

The interface aims to be as transparent and easy to use as possible so that any
user can rapidly and naturally take advantage of the many options provided by
Curvus Pro.

The intuitive equation editor that offers an ideal way of entering mathematical
expressions, is just one out of the numerous original features included in
Curvus Pro.

Also, several visualization options are available, such as:
» Several curves or graphs on the same document

» Variable parameters for curve family plots corresponding to the different
values of the parameter

* Many vector drawing options, etc.

Several numerical evaluation options allow calculating:

» Coordinates, derivatives, tangents, osculating circles at any point of a curve,
a graph or a field

* Roots, extrema and inflexion point as well as intersections of 2D curves
 Integrals over a finite or infinite range.

Numerous dynamic options (animations, QuickTime movies, QuickDraw™ 3D)
provide a powerful way of visualizing the evolution of these objects as function
of some parameters.

Eventually, different exporting options are provided:
» High quality printing
» High definition picture exporting, including PostScript format, etc.
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Getting Used in a Few Seconds

Creating a New Document

After starting the application, or after selecting New under the File menu,
following dialog shows up:
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Select the desired document type by clicking on the corresponding tab. Chose
then a layout from the list and confirm the dialog.

2D Document

Note

The meaning of the word "curve" is here quite general: it includes any element
of a 2D document described by one or several algebraic relations, such as
ordinary curves, vector fields, scalar fields and logic relations.

Creating a New Curve

Select New under the Curve menu. In the appearing dialog, chose the desired
curve type and confirm the dialog.
Note

The different coordinate types are described in the chapter Coordinates on
page 10.

Enter then the expression(s) describing the new curve in the dialog that shows
up and confirm.



Getting Used in a Few Seconds 4

Manipulating Curves

To select a curve, just:

* Click on the curve in the document window, with the Shift key down for a
multiple selection’

or
» Select the corresponding item under the Curve menu.

Selected curves are marked with a "O' in the Curve menu and are highlighted in
the document window.

To modify the expression of a curve, just:

* Double-click on it in the document

or

» Select Modify under the Curve menu after the curve has been selected.

To modify the line attributes of a curve (color, pattern, width), use the following
icons of the Tool toolbar:

Il.: x| [
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To delete the selected curve(s), use the Backspace key.

To duplicated the selected curve(s), chose Duplicate under the Edit.

Modifying the Window Range

Zooming In or Out
To zoom in or out, chose the corresponding item under the Options menu (or

click on the icons and of the Options toolbar). Click then on the point of
the document window to zoom at.

You can also use the icons QE situated in the bottom left corner of the
document window.

Expanding a Rectangular Region
To expand a rectangular region of the window range chose Expand under the

Options menu (or click on the icon =] of the Options toolbar). Drag” then the
desired box to be expanded in the document window.

" Is not valid for vector fields, scalar fields and logic relations
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Adjusting the Window Range

To adjust the window range means to change its values so that all the curves fit
on the visible part of the window. To do so, chose Adjust under the Options
menu or click on the icon =4 of the Options toolbar.

This option can be quite useful when some curve exceeds the current window
range and is so not or only partially visible.

Other Items of the Options Menu
To shift the window range, select Shift and drag the axis origin.
To center the axis origin to the middle of the window chose Center Axis.

To make the basis orthonormal (i. e. same scale for both axis), chose Make
Basis Orthonormal.

To modify the tick-mark spacing (and so the range of the corresponding axis),
chose Extend Tick-Marks, click on a tick-mark and drag it.

Modifying Window Range Values

Chose Document under the Format menu and click on the Domain tab. You
can then enter the different minimal and maximal values for the window range,
select the scales (linear or logarithmic) as well as the reference frame (1 unit =
1 cm on one axis, e.g.). Select the Orthonormal Basis checkbox to keep the
document basis orthonormal when modifying the window range.

You can also double-click on one axis and select the Range tab to modify the
values of the corresponding axis range.

You can also enter directly the different values in the Window Range toolbar
(chose the corresponding item under the Window menu if hidden).

Copying into the Clipboard

To copy the whole picture of the document window into the Clipboard, chose
Copy from the Edit menu (no curve must be selected).

To copy only a part of the window, chose Snapshot under the Special menu or

click on the icon [=] of the Options toolbar. Drag then the desired box in the

document window.

To copy a picture containing only some curves, select the curves to be included
in the picture and chose Copy under the Edit menu (see chapter The
Preferences Dialog on page 47).

Note

To copy a high definition picture, keep the Shift key down while choosing Copy
under the Edit.

" Click and grow box while keeping the mouse button.
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Numerical Calculation

To calculate the coordinates of a point from a curve shown in the window, just
move the mouse cursor over it: a haircross appears which coordinates are
shown at the bottom of the document window.
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To evaluate different values at a point of a curve (coordinates, derivatives,
tangents, etc.), to find a root or an intersection of cartesian curves, or to
calculate an integral, select the items Evaluation, Root Find, Intersection
Find or Integration under the Options menu. You can also click on the icons

(], [=4], [2<] or [£5] of the Options toolbar.

For further information, see chapter Numerical Evaluations on page 27.
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3D Document

Creating a New Graph

Select New under the Graph menu. In the dialog showing up, select the type of
graph you want to create and confirm.

Enter then the expression(s) describing the new graph in the next dialog
appearing.

Manipulating Graphs

The default selection is the most recently

created graph. m

To select some other graph, select the New... HK
corresponding item under the Graph menu. The

selected graph is marked with a "O' in the menu. Eﬁlfléfgl.';nce... {‘rim
To change the expression of the selected graph, Remove

chose Modify.
To modify the appearance of the selected graph, ‘v"" Z=r*2sin3phi ! |

chose Appearance.

To delete the selected graph, chose Remove.

Modifying the Graph Range

Zooming
To perform a zoom:
* Chose Zoom In or Zoom Out under the Options menu

+ Click on the icons and of the Options toolbar

¢ Click on the icons EE' in the bottom left corner of the document window.

Adjusting the Graph Range
To adjust the range to the plotted graphs chose Adjust from the Options menu
or click on the icon of the Options toolbar.

Shifting the Horizontal Range

To shift the horizontal range (i. e. along x- and y-axis), chose Horizontal Offset
under the Options menu (on click on the icon of the Options toolbar). Click
then on the graph and drag the horizontal range while keeping the mouse
button down.
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Modifying the Values of the Graph Range

To modify the minimal and maximal values of the graph range, chose Graph
under the Format menu (or double-click on the graph in the document window).
Click on the Domain tab. You can then change the different values and scales
(linear or logarithmic).

You can also enter directly these values in the Window Range toolbar (chose
corresponding item under Window menu to show it).

Miscellaneous Items of the Options Menu
To center the axis origin, chose Center Axis.
To make the basis orthonormal, chose the corresponding item.

Numerical Calculation

To evaluate different values at a point a of graph (coordinates, derivatives, etc.)
or to integrate a function, chose Evaluation or Integration under the Options

menu (or click on the icon of the Options toolbar).
For further information, see chapter Numerical Evaluations on page 27.

QuickDraw™ 3D

When running Curvus Pro on a Power Macintosh with the QuickDraw™ 3D
extension enabled, the QuickDraw™ 3D mode can be activated by chosing the
corresponding item under the QuickDraw menu.

This mode allows the user to manipulate the graph in real time or to navigate
around it by moving the viewpoint. For further information, see chapter
Navigation on page 32.
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Entering an Expression

The Equation Editor

Curvus Pro provides a user-friendly equation editor, ideal for entering and
manipulating mathematical expressions. Its ease of use allows any user to
rapidly get advantage of it.

The Equation Editor Toolbar

To insert special characters or different symbols, use the toolbar appearing at
the top of the screen, just under the menu bar:

EMIE

A2 EF @] 2] [ = T

Click on a button to insert the corresponding character or symbol. Click on an
arrow to pull down a pop-up menu proposing other symbols.

q

The most recently used symbol is shown in the corresponding button.

Note

See chapter The Preferences Dialog on page 48 to activate or deactivate the
equation editor, and to select the default police.

Moving the Cursor
Use the arrow keys to move the cursor in a field, as well as

reaching numerator or denominator of a fraction, limits of a sum, %0 1+ n
product or integral. a = )
n!

move to the next term, keep the Option key down.

Use the Tab key (with Shift key down) to move to the next (previous)
field of a fraction, sum, integral, etc.

( 5 To expand the selection, keep the Shift key down. To n=0

k=1

Brackets, roots and fractions

To put some text in brackets or into the numerator of a fraction, make it the
selection and type « ( » resp. « / ».

143 = 1+3)
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To remove a symbol such as a root, a fraction, a sum, etc. place the cursor at
the left of the main field (denominator for fraction) and type Backspace.

1

W+ g

Drag & Drop

If the Drag & Drop extension is available on your system, you can easily move
the selection (or copy it when Option key is down) by dragging it with the
mouse Cursor.

Coordinates

Coordinates in the Plane

Curvus Pro uses two kind of planar coordinates:
y

A

[

P X

) Polar
Cartesian

Coordinates in the Space

Curvus Pro uses four kind of spatial coordinates:
V4
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Cylindrical
Spherical
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Operators

11

Scalar Operators

Here is a list of the recognized scalar operators, listed by priority:

Priority 1: A
Priority 2: *e
| =
\
Priority 3: +—
Note

(power)
(multiplication)
(division)

(modulo)

(addition, subtraction)

Curvus Pro provides a particularly simple syntax to define a function by parts.
See chapter Expression Defined by Parts on page 17.

Boolean Operators

Here is a list of the recognized boolean operators, listed by priority:

Priority 1: >
<
3 >==>
£ <==<

1 <> 1=
@ NOT NON
UAND ET &

UOR OU
XOR EOU
T IN DANS

Priority 2:
Priority 3:
Priority 4:

Interval Operators

(strictly greater)
(strictly lower)
(greater or equal)
(lower or equal)
(equal)
(different)
(logical no)
(logical and)
(logical or)
(exclusive or)
(inside interval)

The recognized interval operators are the following:

Priority 1:
Priority 2: C*
Priority 3: E +

@ NOT NON ~ (complement)

(intersection)
(union)
(difference)

A interval is defined with square brackets:

Examples: [a;b]
Ja;bl

[a;b]

(closed interval)
(open interval)
(semi-closed interval)
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Special Operators

Sum: “4”, “Somme” or “Sum”
The syntax is the following:

max

é f(var)

var=min

or, without equation editor: & (var=min..max;f(var))
Example:

10

é.f(n) = f(1)+f(2)+...+f(10)
n=1

Product: “O” or “Prod”
The syntax is the same as for the sum. Example:

n n n n
@ JLRSI I

2 k 1 2 5
1 2 51
k=1

or, without equation editor: O (k=1..5;n"k/k!)

Integral: “d or “Integr”
The syntax is the following:

b\
O

t=a

or, without equation editor: Integr(t=a..b;f(t))

Example:
X 2
2 At
—= 0O =erf(x)
P 0
Derivative: “'”,“""or“{”
Syntax:

ntimes
—

f or fn=f
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Examples:
(@)=
Flay=g 09 __
sin”(p)=-sin(p)
fI3(x)=f"(x)
Note:

L s (o 29 .
f€g(x) = ™ (9(x)) ™ (9(x)) aX(x). So, exp’(ax)=exp(ax) and not exp(ax)a !
Iteration: “ @ ”

Syntax:

n times

f@n(x) = f(f(...F(x)))

Convolution: “ #”

Syntax:
f#g

Example:

¥

f#g(x) = G(t)-g(x-t) dt

-¥
Comments: “"”
Syntax:

..."my comments”...

Recognized Words

Recognized Constants

The following constants are recognized by Curvus Pro (in MKSA units):

p = 3.141592653589...
e = 2.718281828459... (Euler number)
cLight = 2.99792458 e8 (speed of light in vacuum)

e0 = 8.85418782 e-12 (permitivity of vacuum)
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F = 9.648456 e4 (Faraday constant)

G = 6.6732e-11 (Gravitational constant)
gamma = 0.5772157

h = 6.6262 e-34 (Planck constant)
kBoltz = 1.3807 e-23 (Boltzmann constant)
Na = 6.022 e23 (Avogadro’s number)
R = 8.3144 (gas constant)

U = 1.6605655 e-27 (atomic mass)

no = 4dpe-7 (permeability of vacuum)

For complex numbers:
i=j=4-1

And the logical constants:

true,vrai = Boolean yes (result of 0=0)
false , faux = Boolean no (result of 0=1)
nil , nan = not a number (result of In(0), 1+0, etc.)

Recognized Variables

The following variables are recognized by Curvus Pro:
XY zrf,q coordinates (see chapter

on page 10)

t, u parameters for parametric curves

Y speed (=|r| for differential equations)
Note

Constant and variables names are case sensitive: "r" and "R" are names of two
different constants.

Recognized Functions

The following functions are available in Curvus Pro:

Trigonometric

sin coS tan
cot, ctn sec cSsc
asin, arcsin acos, arccos atan, arctan

acot, arccot, actn, arcctn

deg (value in degrees of the angle as parameter)
rad (value in radians...)

grad (value in grades...)

hypot ( hypot(a;b)=sqrt(a®+b?) )
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atan2 (atan2(y;x) returns the arctangent of y/x in [-p,p], according to the signs
of x and y)

Hyperbolic
sinh cosh tanh coth

asinh, arcsinh, argsinh acosh, arccosh, argcosh
atanh, arctanh, argtanh acoth, arccoth, argcoth

Bessel
[(n;x) J(n;x) K(n;x)
Y (n;x)

Complex Numbers
cis (cisB=cos3+isinB) re (real part) im (imaginary part)
arg (argument in [-p,p])

Miscellaneous
abs exp fgamma
fpart (fractional part)
int, ipart (integer part) inv (inverse)

log (basis 10) In (natural) sq (square)
nsqrt(n;x) (n-th root of x) sqrt, sqr (square root)
sgn (sign) fact (factorial)

rnd (random number, O£rnd<1)
min(a;b;c;...) (lower value)

max(a;b;c;...) (greater value)

erf() erfc() lgammal()
gammaP() gammaQ() beta()
Rounding
int(),floor() greatest integer number lower or equal
ceil() smallest integer number greater or
trunc() closest integer number starting from zero
round() rounded ( round(x)=int(x+0.5) )
Note

Various syntaxes are recognized for some functions:

abs(x)=|x| sqrt(x)=sqr(x)=Cx fact(x)=x!
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Note

Function name are not case sensitive: "sin()" and "SIN()" are two names of the
same function.
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Syntax

The syntax of Curvus Pro is the traditional algebraic syntax.

Moreover, Curvus Pro also manipulates complex numbers (w=x+iy or w=x+jy).
The part or the result to be considered (real part, imaginary part, modulus or
argument) can be selected in the pop-up menus of the curve definition dialogs
(see chapter Graph Definition Dialogs on page 43).

Simplifications

The multiplication sign may be omitted if implicit.
Examples:  2x=2*x pré=p*r?
a’x=a**x [=(a®)*x]
(X-2)(x+1)=(x-2)*(x+1)

If a function has only one parameter and if this one does not contain any
operator (except exponent), the brackets can be omitted.

Examples: sinx=sin(x) log2x=log(2x)
cosx*=cos(x?) tan2x’=tan(2x?)
Inabsx=In(abs(x))=In|x|

but sqrt2*x=sqrt(2)*x  Ina+b=In(a)+b

sin(x)sin(y)=sinx*siny * sinxsiny=sin(xsiny)

If a function is taken to a power, following syntax may be used:
fx=(f(x))"
Example: sin®(x)=(sinx)*=sin’x
but sinx®=sin(x?)

Expression Defined by Parts

To define a expression by parts, Curvus Pro offers various syntaxes:
« conditionl: expressionl [; condition2:expression2; etc.] »
or
« expressionl, conditionl [,expression2, condition2, etc.] »
or
« expression, condition; other expression »

You just have to separate condition and expression « : », « , », « ; » or by
Return.
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See following examples:

« sinx, x<0; x(x+1), x>0 » or
« x<0: sinx; x>0: x(x+1) » or 7T\
« X<0: sinx, X(x+1) » or
« sinx, x<0; x(x+1) »

« |x|<1: x* » or
«x? xT 11,1 »

The conditions are Boolean conditions. The Boolean operators are mentioned in
the chapter Boolean Operators on page 11.
Examples: |x|<1
sinx<cosx
x>=0 & x<=2 equiv. to: x1 [0,2] or x30 Ux£2
x 1 [a,b]C[0,2] equiv. to: x1 [a,b]UxT [0,2]

Curvus Pro also treats conditional expressions. The syntax is the following:
IF conditionl THEN expressionl ELSE expression2
or

IF conditionl THEN expressionl
ELSEIF condition2 THEN expression2
[ELSEIF condition n-1 THEN expression n-1...]
ELSE expression n

Example: IF X£E0 THEN 0 ELSE exp(-1/x%)

Using Parameters and Custom Definitions

Variable Parameters

The user can define variable parameters in Curvus Pro, which are helpful to
draw a function for different values of this parameter.

For example, you can plot the function x*+kx*>-1 for k=1, 1.2, 1.4, ... et 2.

In order to define them, there are two possibilities:
» Use the Parameters toolbar (see chapter Parameters Toolbar on page 40)

* In a dialog of curve definition, select Parameters (after having clicked on the
first green triangle), click on the New... button. (see chapter Graph
Definition Dialogs on page 43)
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Once the parameter is defined, you can create any graph with an expression
containing the name of it.

Example:

» Define variable “n” which vary between 1 and 3 in 5 steps of 0.5.

» Create then a curve of equation “sin(nx)”.

» Five curves are plotted, for the values 1, 1.5, 2, 2.5 and 3 of “n”.

Note
An expression cannot make reference to more than one parameter at a time.

Custom Definitions

In Curvus Pro, you can define your own constants or functions, You have two
possibilities for creating your own definitions:

» Use the Custom Definition toolbar (see chapter Custom Definitions
Toolbar on page 41)

* In a dialog of curve definition, select Custom Definitions (after having
clicked on the first green triangle), click on the New... button (see chapter
Graph Definition Dialogs on page 43)

You only need to enter the expression of the constant or function in one of the
following forms:

Constant: xname=expression»

Examples: diameter=2.4
perimeter=p*diameter

phi=(G6+1)/2
Function: «nam(parameters)=expression»
Examples: area(radius)=p*radius mean(p,q)=(p+q)/2
Note

Custom definitions may have references to others.

Plug-Ins

Curvus Pro let you create your own plug-ins. A plug-in is a compiled routine,
which defines a function that cannot be expressed algebraically.

Example: The plug-in "Mandelbrot" returns the maximum iteration
number so that |z| <2, the iteration being defined by

z=2,+c c=a+ib z,=0

See the file "How to create your own plug-ins" for further information on this
subject.
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Note

Plug-ins (easily spotted by their icon @) must be placed in the folder "Plug-Ins”
located next to the application.
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Laying Out a Document

Document Format

To change format and dimensions of your document chose Document under
the Format menu. Following dialog appears:

Decument Farmat
laﬂ-l"I"I"[Hl::nl:s-u-:"lnl"bnlualln"lul"hluﬁi"ll
[T S|l Haw | B
Harnins Endify S 7Y T
Tlassic - —
Lis-lng - |__#pphy |
| Cances | I ] !

Layouts

A document layout contains several parameters of the different formats of axis
and grid (for 2D documents) or of the graph (for 3D documents). Many layouts
are available when creating a new document (see chapter Creating a New
Document on page 3).

To create a new layout from the current document, click on New. You can apply
the selected layout to the current document by clicking on Apply. To change an
existing layout according to the current document, click on Modify. Eventually,
you can rename or erase a layout by clicking on Rename or Erase.

Dimensions

Click on the Dimensions tab of the Document Format dialog to modify the
document dimensions. Several predefined formats are available in the pop-up
menu.

Note

You can also change directly the size of the document by clicking in the Size
corner (bottom right) of the document window and keeping either the Option
key or the Command key down.
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Adding Drawing Objects

You can add several types of drawing objects (texts, circles, rectangles, lines,
marks, equations, etc.) to a Curvus Pro document in order to illustrate it by
some drawings or explanations.

These objects can be selected, moved and deleted as in any other common
application: with the mouse, keeping the Shift key down for a multiple selection,
typing Backspace to deleted the selected objects.

Note
You may use the Arrow keys to adjust the position of some objects.

Tools Toolbar

You can use the Tools toolbar to add some vector drawing objects. These are
more or less the same as the one encountered in any other vector drawing
application.

]
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Click on one icon of the toolbar to select the corresponding object and click
somewhere in the document window to insert it.

Note
To keep an object selected in the toolbar, double-click on its icon.

The Object Menu

Use the items Move Forward, Move Backward, Move to Front and Move to
Back under the Object menu to modify the
piling order of the selected objects. Object

Chose the items Arrow and Specifications ST AT #+

to modify the appearance of the selected Move to Front  {r¥+
object. Move Backward -

Move to Back 3=
Use the items Attach to Real Field and

Detach From Real Field to attach or detach m
the selected objects to or from the real field. Specifications...
See the illustration under to understand the + Attach To Real Field

difference between an object attached and Detach From Real Field
detached from the real field.

Group H#E O
Lingroup 3G
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Before Expand: After Expand:
This object is attached to the real field. It stays centered on the
/point (0;0.75).

/| I

p g/ \\\4 Y

This object is detached from the real field.
It remains in the lower right corner
of the document.

Difference between an object attached and detached from the real field.

Use the items Group and Ungroup to group and ungroup the selected objects.

The Special Menu (2D Document)

In a 2D document, you can add horizontal or vertical lines by choosing the
corresponding items under the Special menu and by click on the desired point
of the document window. To modify the position of an existing line, either
double-click on it or just drag it.

To insert a text zone containing the value of an algebraic expression (updated
continuously), chose Insert Expression Value and click on the desired point of
the document window. In the dialog that shows up, you can enter the legend
and the expression.

Expresziss Value

Lenend: | Emenrger |

1
— kv
Z ?|

[ A T T |

Fnde; | Radiany :|
| comce | | ok |

Expression;

Note
The expression may contain any custom definitions.
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Modifying Axis and Grid Appearance in a 2D Document

Modifying the Axis

To modify the axis of the current document, chose X-Axis or Y-Axis under the
Format menu, or just double-click on one axis in the document window.
Following dialog appears then:

L]
E wasihle
/ Rompe’, Farmat', umbers Fomt'y
[ La=gpaasthimic
by |-.'.| |
bdmeimuim: |‘5- |
bl W= Pl R
[ Lines A Moy = ]
By 1 | Lotz %

bodisd Tick=ABAFKE
[ Lines [ romabprang

|:| pErT | nr Teek-kiark

[Cprestese | | cances | |[ o ]

Click on the Range tab to change the range value, the scale (linear or
logarithmic) and the tick-marks.

Click on the Format tab to change the appearance, the position and the
numbering of the axis.

Click on the Number tab to change the number format used for the numbering.
Select the Default item to use the default number format of the document (see
chapter The Preferences Dialog on page 48)

Eventually, click on the Font tab to change the appearance of the font used for
the numbering.

Modifying the Grid

To modify the appearance of the document grid, chose Grid under the Format
menu.

In the appearing dialog, you can select the coordinates type (rectangular or
polar), the main and second grid specifications as well as the background color
and the document bounds.

Note

To change the document margins, chose Document under the Format menu
and click on the Margins tab.
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Modifying the Graph Appearance in a 3D Document

To modify the graph appearance, chose Graph under the Format menu, or
double-click on the graph in the document window. Following dialog appears:

Graph Format
oo i l"l'ulr-l"lm-'-n'..':'llflh'-pn:l"lliﬂh'l.ﬂﬁ
pt-i i
n [ [~ |3 |
[ Lingan i s %0
Yeluis
w |5 - Is
[] Lssparsthmic Scale
LT
= |5 - |5
[] Lssparsthmic Scale
| Frevew | | cances | | ok |

Graph Range

25

Click on the Domain tab to change the graph range as well as the different
scales.

View

Click on the View tab to change:
» The angle of view by entering the rotation values
* The perspective kind

* The three axis ratios. Proportional means a width of the graph proportional
to its range, as the percentage indicates a fixed width.

Bounds

Click on the Bounds tab to select:

» The different colors of the graph faces (x=0, y=0 and z=0 planes)
* The background color

* The three legends.

AXis

Click on the Axis to modify:
* The three axis
* The tick-marks and numbering
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* The main and second grids.

Note

The tick-mark spacing value is automatically set according the value entered in
the Preferences dialog (see page 46).

Number and Font

The two tabs Numbers and Font reveals options to change the format and
appearance of the numbering. See page 24 for the details about these options.

Light

Click on the Light tab to modify the light source (or the lighting in QuickDraw™
3D mode).
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Numerical Evaluations

In Curvus Pro, you can easily perform numerical evaluations, such:

» Calculating the coordinates of a point from a graph, its various derivatives,
tangents and osculating circles, etc.

« Finding’ roots, extrema and inflexion points
* Finding the intersection of two cartesian curves
» Integrating the area under a curve, the volume of a graph, etc.

Note

It is possible to enter a expression in any field where a real number is required
(e.g. "exp2", "2p", "(1+CB)/2", etc.).

2D Document

Evaluating Values at a Point

To evaluate different values at a point of a curve, select Evaluation under the
Options menu or click on the of the Options toolbar.
Following dialog appears:
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Select in the top left pop-up menu the desired curve. Fill in the field(s) under it
and click on Calculate.

It is also possible to move the mouse cursor over the document window if the
option Follow Mouse is checked.

The values of the several coordinates, derivates, etc. appears in the middle box.

In the right-hand part of the dialog (which can be masked or shown by clicking
on the little green triangle), it is possible to select the elements to be shown in
the document window.

Click on the Plot button (or click in the document window at the desired place)
to insert the drawn objects into the document.

For vector and scalar fields, the right part of the dialog is a little bit different:

" Only available for cartesian curves in a 2D document.
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Click on the Plot a Field Line button to insert a field line starting from the
calculated point. You can also acheive this by click on the document window
with the Option key down.

Root Finding”

To find roots, extrema or inflexion points of a curve, chose Root Find under the
Options menu or click on the icon of the Options toolbar.
Following dialog appears:
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Select in the pop-up menus of the upper part the kind of find to perform, enter a
starting value and click on Find.

Finding Intersection between Curves

Chose Intersection Find under the Options menu or click on the icon of
the Options toolbar. The procedure to follow is the same as the one described
above.

Integrating

To calculate the area of the surface under a curve, the length of an arc, the
volume of lateral area of a rotation surface, chose Integration under the
Options menu or click on the icon of the Options toolbar.

Following dialog appears:

" This option is only available for cartesian curves of type y(x).
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Select in the upper part the graph, the kind of integration to perform and the
method to be used. Fill in the two integration limits (click on the triangles for
infinite limits) and click on Calculate.

You can calculate the area between two curves by selecting the checkbox
Difference.

Select the checkbox Draw Area if you want the calculated area to be drawn in
the document. This latter can be removed by chosing Remove Integrated Area
under the Special menu (the curve must be selected).
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3D Document

Evaluating Values at a Point

To evaluate different values at a point of a graph chose Evaluation under the
Options menu or click on the icon of the Options toolbar.
Following dialog apears:
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Select in the top left pop-up menu the desired graph (surface, field or curve). Fill
in the following fields and click on Calculate,

The calculated values (coordinates, derivatives, etc.) are shown in the middle
box.

Important

The following options are only available when the QuickDraw™ 3D mode is
activated.

In the right-hand part of the dialog (which can be masked or shown by clicking
on the little green triangle), it is possible to select the elements to be shown in
the document window. You can also spin the graph with the mouse by dragging
it in the document window.

For vector or scalar fields, this part is a little bit different:
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Click on the Plot a Field Line button to insert a field line starting from the
calculated point.
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Dynamic Options

Animations

Varying a Parameter

Once your 2D document contains one or more families of curves (see chapter
*** on page ***), you may display only the curves corresponding to one value of
a parameter. To do so, chose Vary a Parameter under the Curve menu.
Following dialog appears:

Vary a Farameber
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Select the parameter to vary and click on the icon El to start the animation or
move the cursor to change the value of the parameter.

Creating a QuickTime Movie

In order to visualize the evolution of some curves or graphs as function of
certain parameters (or when changing the window range), you can create
QuickTime movies with Curvus Pro.

Chose Animation under the Special (in a 2D document) or Options (in a 3D
document) menu or click on the icon (or in a 3D document). Following
dialog appears:
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In the top left part, select the parameter(s) which value is to be varied. For that,
chose the desired parameter (or custom constant) in the pop-up menu, check
the box next to it and enter the initial and final values. Select the checkbox
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Show if you want the parameter value to be shown at the bottom of the
animation.

In the other fields, you may enter different animation parameters (frame
number, rate, size, compression, etc.).

In the bottom part of the dialog, you can chose the initial and final window range
(as well as the view angles in a 3D document).

Confirm the dialog to create the QuickTime movie.

You may also create QuickTime movie from a navigation path. See chapter
Navigation on page 32 for further information.

Using QuickDraw™ 3D

QuickDraw™ 3D is a system extension providing three dimensional object
visualizing and handling. Curvus Pro take advantage of it for real time 3D-graph
manipulation.

Note
This extension is not available for 680x0-based machines.

To activate this display mode (of course only available for 3D documents),
select Activate QuickDraw™ 3D under the QuickDraw menu. This mode is used
exclusively for the graph display so that no vector drawing isn't shown nor can
be used.

Important

Be sure that this extension is located in the Extensions folder of your System
Folder.

Navigation

Once QuickDraw™ 3D is activated, chose Navigation under the QuickDraw
menu to swap to the navigation mode.

Follow toolbar appears then (click on the green triangle to show or mask the
right part):
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In this mode, you can move the viewpoint location or navigate about (or inside!)
the graph.

Moving

There are several ways of moving the viewpoint location:

* By clicking with the mouse at any direction in the document
* By using the Number Pad keys

» By using the right part of the toolbar above

» By following a curve (see paragraph Options below)
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Note

Keep the Shift, Option, Control or Command keys down to change the
navigation speed.

Recording the Path
You can record the path you're moving on by clicking on the icon |E| To pause
the recording, click on @

Once a path is recorded, you can follow it again by using the icons E @ and

]

You can also click on the progress bar to jump to the corresponding position.

Options
Click on the icon [f2=-| to make the following dialog appear:
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You can chose different playback modes (loop, back and forth) and recording
modes (Transition):

* The Continue mode record each move.

* The Positions mode record each position (each time you click on the icon
El) and then perform a smooth transition between each, in the order they
were recorded

» The Follow the Curve mode (only available for parametric curves and

differential equation solutions) defines a path follow the selected curve. It
cannot be modified.
Creating a QuickTime Movie

Click on the icon to create a QuickTime movie from the recorded path.
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Deactivating Navigation Mode

Just click on the close box of the Navigation toolbar or chose Close under the
File menu. The recorded path is kept in memory and can saved with the
document file.

Note

The navigation mode is automatically deactivated when another document is
brought to the front.
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Advanced Features

Numerical Data

In a 2D document, you can add a curve defined by a set of numerical data
corresponding to an array of values. For that, chose Numerical Data under the
Special menu. In the dialog appearing, you can enter a set of points or import it
from any text file.

Slide Show

A slide show can be performed from a folder containing several Curvus Pro
files. They are displayed in turn during a certain amount of time. Many slide
show options are available.

Creating a Slide Show

Create a folder (in the Finder) in which are placed or saved a set of 2D, 3D
documents or QuickTime movies.

Slide Show Options

You may define some options for each of these files. To change them, open the
file and chose Slide Show Options under the File menu.

Important
Do not forget to save the document after modifying any slide show options.

2D Document

The slide show options for a 2D document can be modified in the following
dialog:

§iaie SR SERIND ¥

[ ypdary Dradion =¥
W Default -

@ e (e |
[ Wy Farame e

III-I-I-IEI;I{lii

You can specify a custom display duration in the top left part. Click on the
Image button to add a title picture which is shown under the document during
the slide show.

Select the Vary Parameter checkbox to let the value of the selected parameter
being varied during the slide show (see chapter Navigation on page 32).
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3D Document
The slide show options for a 3D document can be modified in the following

dialog:
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The options of the upper part are the same as the ones for a 2D document. On

the other hand, you may chose between three display modes:

* Normal: the file is simply opened.

» Transition: during the slide show, a transition is performed between to
selected viewpoints. These can be defined in the lower part of the dialog.
Click on Define to change a position according to the current point of view.

» Navigation: the recorded navigation path (see chapter Navigation on page
32) will be followed during the slide show.

Starting the Slide Show

To start the slide show, chose Launch Slide Show under the File menu.

In the dialog appearing then, chose the folder containing the files to be shown
and confirm it.

During the slide show, you can skip to the next document with the arrow keys.

Exporting

PICT File

To export the picture of the current document into a PICT file, chose Export,

PICT File under the File menu.

Data Array

To export a data array corresponding to a curve or a graph into a text file chose
Export, Data Array under the File menu.

Select the High Precision checkbox to export the values with a maximum
number of digits. Otherwise, the current number format is used.

The created file can be then opened by any spreadsheet.
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3DMF File

If the QuickDraw™ 3D mode is activated you can export the graph as a 3DMF
model by choosing Export, 3DMF File under the File menu.

The created file can be read by SimpleText, e.qg.

Sound

Curvus Pro provides a sound synthesizer that create sound according to a
cartesian curve of type y(x).

Chose Synthesize Sound under the Special menu. In the dialog appearing,
you can change the different parameters. Click on Play to play the sound or on
Save to save it into a file.

The created sound can be played again just by double-clicking on it in the
Finder.
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The Toolbars
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Each toolbar can be shown or hidden from the corresponding item of the

Window menu.

Tools Toolbar

Equation Editor

Mark Sign (to mark a point
[ in the document)

|

s

i
N

1
(5

9 4

£ |
& || [
/

SaEaREEER

Bézier Curve

I— Background

attributes (or
integrated area)

Line attributes (or
object frame)
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Options Toolbar (2D)
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[Hcocsiecannie [@
Expand \ M Axi
DO(;ngnt \ & f.‘::l‘ S ove Axis
egion — )
Adjust | fﬂ-’;-f ' d .
N - /— Center Axis
&
- =t N
Evaluaton — | ~
\ .
| ST Jﬁ \ Root Find
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Y A— Integration
Snapshot —
Create Animation
(QuickTime Movie)
Options Toolbar (3D)
Z-Axis Rotation — ; ;
Y-Axis Rotation
| /

Free Rotation T

/— Grow
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Zoom Out

Create Animation
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Horizontal Offset ——\ i @gb ‘fi}’ i
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oom In —’/ ,@'

Evaluation —/ %ﬁ %@9

1

Redraw J

Automatically

(QuickTime movie)

Redraw Now
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Parameters Toolbar

[0 :inniin Parameters DI A
n=0...10
k=1,3,7,10

!
Definitions of the parameters Delete the parameters
« Tocreate anew parameter, click on a Click on this icon to delete the
; selected parameters. If no parameter
empty line. ; :
is selected, all parameters will be

e Toselect aparameter, click once on it. deleted.
Comment. Save the parameters

To select several parameters, keep the

) Click on this icon to save
Shift or Command key down.

the parameters in a file.

To modify a parameter, double click on it.

Load parameters
Move a parameter —— Click on this icon to load

parameters from a file.

Click on on arrow to move a
parameter in the list in order to have
it sorted in the desired order.

Note

See chapter Variable Parameters on page 18 for further information about
using such parameters.
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Custom Definitions Toolbar
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flxl=zinx+cos:

-0.01 4001 401+

« Tocreate a new definition, click on a
empty line and type a new expression.

« Toselect adefinition, click on it.
Comment:

To select several definitions, keep the Shift
key down (or Command key for
discontinuous selection).

To modify a definition, double-click on it.

To copy into the clipboard the expression
of the selected definitions, choose Copy in
the Edit Menu.

Increment bar

Select a definition (typically a constant),
and click on this bar to increment or
decrement its value.

Note

o @ & @ C

Click on this icon to delete the
selected definitions. If no definition is
selected, all definitions are deleted.

: lefiniti

Click on this icon to save
the definitions in a file.

| the definiti

Click on this icon to load
definitions from a file.

lefiniti

Click on on arrow to move a
definition in the list in order to
have it sorted in the desired
order.

See chapter Custom Definitions on page 19 for further information about using

such custom definitions.

Window Range Toolbar

[0 ioinnnnnnnnns Window Range (Hinnnnnnnnnnni @
o E | =
w: |-3.4694 [ ... [3.4694 |

Enter the boundary values of the window range. Click on the triangle to restore

a recently used range.
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Calculator Toolbar
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Mode

Choose the mode
(degrees, radians,
grades) for the
trigonometric
calculations

Note

Insert a pre-defined function or

constant Confirm

Computes the
expression and
shows the result.
Equivalent to typing
Return or “="

Sl Calewlatof fiiiinnifis H]

Mode : degrees =
(1+45)42=1 618

Expression

Click on the zone to select the text, type in the
expression you want to evaluate and confirm.

To use the previous result, click once more on the
right of the “=" sign and type in the new expression.

All calculations are performed with complex numbers (either i or j is recognized
for the imaginary part).
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Graph Definition Dialogs

Most curve and graph definition dialogs have a similar common structure, which
main features are described below.

For some special graphs, the dialog presents some specific options that are
described starting from page 45.

When a new curve is created or when an existing curve is modified, a dialog
similar to the one below appears:
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Note
Click on the green triangles to expand the dialog and show further options.

Entering an Expression

In the upper part of the dialog, enter the expression(s) describing the graph. For
some graphs, you may also enter the range of the parameter(s).

Note

You may enter an expression in any fields that requires a numerical value. For
example, you can define a polar curve for f between "0" and "2p". You may
even make reference to a parameter in any of these fields.
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Click on this triangle to restore a recently
1<, AYNrecainn
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Palar Fengbigs
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Farameter
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Parameters and Custom Definitions

Click on this triangle to
insert a predefined
constant of function

In the middle part, you can create, modify or delete a parameter or a custom

definition.

w Parsssedery usinm Dessstions

i Pargmseiery
o Cmrbges Definispss

Double-click on a element of the list to modify it.

e AD

e

Clear

See chapter Using Parameters and Custom Definitions on page 18 for

further information.
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Miscellaneous Options

The bottom part of the dialog provides miscellaneous options specific to each
kind of graph. Following options are the most frequent:

Activate this option to better
Mode for plot the curve at its extremities

trigonometric
calculations

o hEsrelasans
Fiaiia durk 2 Best Extresssioy

fl:lmple-.- | Fecall Prd ] Ma A=Al simeg during Expeset
[Cwear ]

Part of the result to be
displayed, when using
complex numbers.

Specific Options

Cartesian Curves y(x)

Vertical Asymptote If this option is activated, the curve is plot with a
continuous line. Otherwise, vertical segments
corresponding to vertical asymptotes or "jumps" are
not drawn. See the example below:

y=tan(x)

y=trunc(x) | } I } | } '

without (item unchecked) with (item checked)

Example of plot with and without the option Vertical Asymptotes.
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Differential Equations
That are the boundary conditions for the initial time

Initial Conditions
(usually zero).

HiTerential Eguatisss

Iidinl Conditons

order: [2 | a= as o

ve |2

L]

S v
¥ |- —=—x
T

Geal r
[ P ST =

Farameber
o [ 180 | o= |0 |

Note
For a system of differential equations of order two or greater, you can use the

variables «x’» and «y’» (or «x’» et «y”»), as well as «v» ( =Qx’*+y’?) , the

velocity).
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The Preferences Dialog

This dialog provides numerous options and is therefore quite large.
Nevertheless, the meaning of most options is quite obvious. Only the few that
may be confusing are described below.

The generic preferences are used when no document is available or if the
current document type is not concerned (like the 3D Document tab for a 2D
document). See the first line under the tabs.

Note

Click on the Default button to restore the default values for the displayed
options.

2D Document

Click on the 2D Document tab to obtain following dialog:

Freferences
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Smooth Curves If this checkbox is selected, the curves are smoothed

when they are exported (not in high definition). This
will avoid some "steps" to appear when the picture is
exported toward another application.

Note

The printing quality will be the best if using a PostScript printer thanks to the
PostScript data included to the exported picture.

Follow Mouse When the item Stop on Roots of y is checked, and
while moving the mouse cursor over a root of a curve
in the document window, the "exact" value of the root
will be calculated. A tick sound is then heard.
Analogously, when y' is checked, Curvus Pro will
round the haircross position to the next extremum of
the curve.
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Haircross Check this option to activate the haircross appearing

when moving the mouse cursor over a curve in the

document window.

3D Document

Click on the 3D Document tab to obtain following dialog:

Preferenioes
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Automatic Proportions Check this option if you want the proportion ratios to

be adjusted automatically according to the types of
the graphs contained in the document (see chapter

View on page 25). For example, a graph containing

one cartesian curve z(x,y) will have following ratios:
100 % (maximum width)

xandy
z

Absolute Rotations

Root Find

proportionnal

When this option is checked, rotations are done
about the absolute axes instead of the graph axes.

Click on the Root Find tab to modify the parameters concerning the find of root
or intersection (only for 2D document).

Numbers

Click on the Numbers to change de default number format.

Equation Editor

Click on the Equation Editor tab to modify the parameters for the equation
editor. You can enable or disable it, select the default font and the key

combination for line feeds.
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General
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Click on the General tab to display the follow dialog:
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Troubleshooting
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Bad Quality Printing

When | export an image toward another application and I print it, the curves
show staircase defects

This is a problem that occurs in the majority of applications. This happens
because, before being printed, all images are converted to 72 dpi’, leading to a
loss of quality for high definition images.

are enlargements):

Look at the examples shown at right (these

The first curve was printed directly in
Curvus Pro, without any defects.

The middle one has been exported to

Printed in Curvus Pro

another application. The very annoying

staircases show up in the printout, even if ‘ J
the curve has been exported with high | |
definition.

Exported toward another

The last one has been exported with the application

smoothing option and the printed in
another application. Even so very slight
iImperfections persist (because the printout
is done with 72 dpi and not in 360 dpi like

in Curvus Pro), the quality is much better
than before.

Exported with the smoothing
option

To solve this problem, be sure that the option Smooth Curves in the
Preferences dialog (see page 47) is activated (normally on), then copy the
image normally (without keeping the Option key down). You will get the best
quality in your printouts.

Important
Avoid reducing the size of an image containing curves after exporting. It is

better to reduce the size of the original document before exporting the image.

" dpi = dots per inch
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The curve doesn’t show up

» The curve overruns the selected domain of representation. Choose the item
Adjust under the Special menu.

» The curve is not defined, this means that the equation returns an undefined
number (for ex. dividing by zero, log(x) for x<0). To check this, choose the
item Value under the menu Options, and check a few points. You should
see that the result is “undefined”.

Contacting & Updating

Don't hesitate to give us part of your opinions, comments or questions! This is
the way we improve our product! Bug reports are also welcome.

Address

Arizona

Simon & Jean Bovet
Sablons 35

2000 Neuchatel
Switzerland

Phone: +41 32 725 39 04

E-mail: arizona@curvuspro.ch

Internet

The latest version of Curvus Pro is always downloadable at the following
address, as well as several tutorial files, etc.

http://www.curvuspro.ch
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